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Related Documents 

Through related documents, users can quickly understand the positioning of this manual and the 
correlation between manuals and products. Go to HIWIN MIKROSYSTEM’s official website → Download 
→ Manual Overview for details (https://www.hiwinmikro.tw/Downloads/ManualOverview_EN.htm). 
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Preface 

This manual provides detailed information on the operation of PLC software KV STUDIO when E series 
MECHATROLINK-III drive is used with KEYENCE KV-7000 series PLC.  
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Specifications of Software/Hardware 

Name Version of Software/Firmware 

E Series MECHATROLINK-III Drive 
Software (Thunder): 1.9.16.0 or above 

Firmware: 2.8.16 

KEYENCE KV-7500 
Software (KV STUDIO): 11.61 or above 

Firmware: 2.400 or above 

KEYENCE KV-XH04ML Firmware: 1.106 or above 

  



vi 

Table of Contents 

 

1. Communication and module setup .................................................................................................................. 1-1 

1.1 Introduction of hardware device ..................................................................................................... 1-2 

1.2 IP setting and connection ............................................................................................................... 1-4 

1.3 Axis configuration ......................................................................................................................... 1-12 

 
2. Parameters setup ............................................................................................................................................. 2-1 

 
3. Trial run ............................................................................................................................................................ 3-1 

3.1 Positioning control .......................................................................................................................... 3-2 

3.2 Starting speed, acceleration and deceleration rate/time, acceleration curve ................................. 3-4 

 
4. Origin return ..................................................................................................................................................... 4-1 

4.1 Immediate Z-phase origin return .................................................................................................... 4-2 

4.2 Limit switch rising edge ................................................................................................................... 4-3 

4.3 Origin sensor and Z-phase ............................................................................................................. 4-4 

 
 



HIWIN MIKROSYSTEM CORP. 1-1 

1. Communication and module setup 

                                                                                                                                  

 

1. Communication and module setup .................................................................................................................. 1-1 

1.1 Introduction of hardware device ..................................................................................................... 1-2 

1.2 IP setting and connection ............................................................................................................... 1-4 

1.3 Axis configuration ......................................................................................................................... 1-12 

 

  



Communication & module setup E Series MECHATROLINK-III Drive Complete Setup with KEYENCE KV STUDIO 

1-2 HIWIN MIKROSYSTEM CORP. 

MD37UE01-2405 

1.1 Introduction of hardware device 

 
Figure 1.1.1 

KEYENCE KV-7500 is a controller composed of a CPU unit and one or more positioning motion units. 
For the first use, users need to combine CPU unit and positioning motion unit and prepare a 24 VDC 1.8 
A power supply for CPU unit. CPU unit is mainly used to connect with the computer, and positioning 
motion unit is mainly used to connect with the drive. 

 
Figure 1.1.2  
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 Field A 
Model of CPU unit. 

 Field B 
LCD screen display. 

 Field C 
Computer USB port. 

 Field D 
CPU unit network port. 

 Field E 
LED display lights. 
Red light: Unit connection failure. 
Green light: Successful unit connection. 

 Field F 
Model of positioning motion unit. 

 Field G 
Motion unit network port. 
Users need to adopt Keyence's special network cable for motion unit and drive; ordinary network 
cables may not be able to communicate successfully.  
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1.2 IP setting and connection 

1. For first-time setup, connect USB cable and network cable to CPU unit and the computer, and open 
KV STUDIO software interface. 

 
Figure 1.2.1 

2. Create a new project. 
(In this step, press NO in "Confirm unit setting information" to prevent automatic generation of unit 
configuration, which will be set in step 6.) 

 
Figure 1.2.2  
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3. Set IP address to 192.168.0.100, which is in the same network domain as the controller. 

 

Figure 1.2.3 

4. Switch KV STUDIO mode to Editor, so that the subsequent operations could be carried out. 

 
Figure 1.2.4  
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5. Select USB as communication path. 

 
Figure 1.2.5 

6. Click Unit configuration on the upper left side, and then right-click to select Unit Editor. 

 
Figure 1.2.6  
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7. Click "Acquire the configuration information of the unit connected to the PLC" and press Yes to read 
the existing positioning motion unit model of the user. 

 
Figure 1.2.7 

8. When the models of CPU unit and positioning motion unit appear, click OK on the lower right side. 

 
Figure 1.2.8  
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9. Check if the model under Unit configuration is consistent with the model of actual controller. 

 
Figure 1.2.9 

10. Check if the communication path is USB, and press PLC Transfer > Execute. At this time, the display 
light on the upper right side of the positioning motion unit will turn from red to green (refer to Field E in 
Figure 1.1.2), representing successful setup of CPU unit and positioning motion unit. 

 
Figure 1.2.10  
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11. After completing unit editor settings, select Serial as communication path and click Comm settings > 
Ethernet > Search destination. 

 
Figure 1.2.11 

12. Click the network card that is connected to CPU unit and then click on Execute. 

 
Figure 1.2.12  
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13. After pressing Execute for a few seconds, the results will be displayed below. Select the connected 
unit type and click Select. 

 

Figure 1.2.13 

14. Click OK to complete the connection. 

 
Figure 1.2.14  
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15. Switch KV STUDIO mode to Monitor, and check if the motion unit models are turned to green lights, 
indicating the connection between PC and CPU unit is established. 

 
Figure 1.2.15 

16. Check if the communication type of the drive is MECHATROLINK-III and is set to “Drive ready” state 
(For detailed setting operation, please refer to "E Series Servo Drive Thunder Software Operation 
Manual"). Set Access to Controller so that the positioning motion unit of Keyence controller can be 
connected to the drive. 

 
Figure 1.2.16  



Communication & module setup E Series MECHATROLINK-III Drive Complete Setup with KEYENCE KV STUDIO 

1-12 HIWIN MIKROSYSTEM CORP. 

MD37UE01-2405 

1.3 Axis configuration 

1. Switch KV STUDIO mode to Editor. Click the positioning motion unit which will be connected to the 
drive and open Axis configuration setting. 

 
Figure 1.3.1 

2. At this time, the following screen will appear. Double-clicking Servo on the right, and the icon of a 
servo motor will appear on the left. Please enter the relevant information of the drive on the lower 
right side. 

 
Figure 1.3.2 
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3. Open the cover of drive panel and observe SW1 and SW2. The arrow direction of knob indicates 
the station address of the drive, SW1 refers to tens digit, and SW2 refers to units digit. However, 
some station addresses are not supported by the drive, as shown in the table in Figure 1.3.4. If 
SW1=0, the value of SW2 cannot be a number from 0 to 2; if SW1=F, the value of SW2 cannot be a 
number from 0 to F. If the station address of the drive is the above number, please turn the knobs of 
SW1 and SW2 to avoid the above range and restart the power. Finally, enter the station address of 
the drive to Station address shown in Figure 1.3.4. 

 
Figure 1.3.3 

 
Figure 1.3.4 

Note: 

If the drive is set to gantry, the slave’s SW2 needs to be set to 8, otherwise it may cause gantry communication 

errors.  
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4. After completing station address setting, do not set up coordinate transformation at this time, which 
will be set after coordinate unit in chapter 2. 

 
Figure 1.3.5 

5. Click PLC Transfer to import the existing setting values into the controller. 

 
Figure 1.3.6  



E Series MECHATROLINK-III Drive Complete Setup with KEYENCE KV STUDIO Communication & module setup 

HIWIN MIKROSYSTEM CORP. 1-15 

MD37UE01-2405 

6. Press Execute. 

 
Figure 1.3.7  
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1. Click Axis control setting and set unit of coordinate and place of decimal point. Then, click coordinate 
transformation at the top. 

 
Figure 2.1 

2. After setting the relevant parameters, click Advanced setting to complete the setting of encoder 
resolution and servo electronic gear ratio. 
The settings in Figure 2.1 and Figure 2.2 take resolution of 8388608 pulse/rev for one motor revolution 
(1mm) and 1:1 electronic gear ratio as an example. 

 
Figure 2.2  
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3. Turn on Axis control setting and complete parameter settings in operating speed, JOG, and origin 
return. Absolute position detection system is set according to the encoder: incremental type is set 
to INC; absolute type is set to ABS. 

 
Figure 2.3 

Note: 

The highest operation speed must be equal to the rated operation speed of the motor. The setting of origin return, 

JOG, operating starting speed, high speed, acceleration and deceleration rate/time, and acceleration curve are 

based on the same concept, which will be describe in detail in chapter 3. The unit of 1 mm/s here indicates that the 

motor speed is 1 rev/s (60 rpm).  
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4. After the parameters are set, click PLC Transfer and switch KV STUDIO mode to Monitor. 

 

Figure 2.4 

5. To save this project, switch KV STUDIO mode to Editor, and click File > Save project or Save project 
as and set project name and position to complete the archive. 

 
Figure 2.5  
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Supplementary note: 
If users use KV STUDIO for the second time and would like to adopt the previous project, please click 
File > Open project and select the previously set project or click the area in orange boxes in Figure 
2.7 to read the previous PLC project. 

 
Figure 2.6 

 
Figure 2.7  
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3.1 Positioning control 

1. Check if the KV STUDIO mode is Monitor. Click the positioning motion unit set by the parameter and 
right-click > Trial run > Positioning control > Axis. 

 
Figure 3.1.1 

2. Check if “Axis error” turns to red light. If there is an error, click Error clear first; if there is no error, 
click Cancel OP. Enable. When "Operation ready" turns to green light, click Cancel servo ON and 
wait for “Servo ready” light to turn green. The action sequence cannot be reversed. After completing 
"Servo ready", users can execute JOG movement in forward and reverse directions. 

 
Figure 3.1.2  
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3. When JOG is moving, users can open Scope in Thunder, select “7. Motor velocity” to check the 
speed feedback of the motor, and check if the set speed command is consistent with actual speed 
feedback of the motor. According to 5.00 mm/s JOG high speed set by the parameter, the 
corresponding speed is 300 rpm. 

 
Figure 3.1.3 

Note: 

(1) If users would like to achieve the position, speed, acceleration, and deceleration set by the positioning motion 

unit in equal proportion, please set drive parameter electronic gear ratio Pt210 and Pt20E to 1:1. 

(2) Thunder 1.9.20.0 or above and drive firmware version 2.8.16 or above support the electronic gear ratio setting 

other than 1:1. 
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3.2 Starting speed, acceleration and deceleration rate/time, 

acceleration curve 

1. Complete the parameter setting in Figure 3.2.1 with the above-mentioned setting method. 

 
Figure 3.2.1 

2. Open Thunder > Tools > Real-time data collection and click Start to capture the speed command 
dPosVelCmd. 

 
Figure 3.2.2  
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3. Execute JOG movement in forward direction for a few seconds and release it, wait for the motor to 
stop. 

 

Figure 3.2.3 

4. Open Thunder > Tools > Real-time data collection, click Stop and then press Graph (refer to 
Figure 3.2.2) to generate Figure 3.2.4. 

 

Figure 3.2.4  
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5. According to the setting in chapter 2 that the resolution for one motor revolution (1mm) is 8388608 
pulse/rev, 1.00 mm/s starting speed corresponds to 60 rpm actual speed; 25.00 mm/s JOG high 
speed corresponds to 1500 rpm actual speed. 
Choose SIN for acceleration curve since the speed command from starting speed to high speed is in 
a curved shape; choose a straight line for deceleration curve since the speed command from high 
speed to starting speed is in a straight line. 
The acceleration/deceleration time of 0.010 mm/s/ms corresponds to actual acceleration of 0.6 
rpm/ms, indicating that the speed increases by 0.6 rpm every 1 ms. 

 

Figure 3.2.5 
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4.1 Immediate Z-phase origin return 

1. Use the above-mentioned setting method to complete the setting of origin return method and direction 
in Figure 4.1.1. 

 
Figure 4.1.1 

Note: 

Immediate Z-phase origin return can be used without any external input signal. This method can be adopted if 

users cannot input external P-OT, N-OT, DOG, EXT-PROBE1 signals to the drive. If users would like to use 

external P-OT, N-OT, DOG, EXT-PROBE1 signals for origin return, I/O setting of the drive must be completed first. 

(For detailed information, please refer to " E Series Servo Drive Thunder Software Operation Manual.") 

 
2. After "Operation ready" and "Servo ready" turn to green light, click Origin return. The motor will move 

in origin return direction and search for the encoder origin (index). It will stop after finding the origin. 

 

Figure 4.1.2 

Note: 

When using with an incremental encoder, users need to check if the encoder supports index signal output.  
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4.2 Limit switch rising edge 

After "Operation ready" and "Servo ready" turn to green light, click Origin return. When the motor moves 
in reverse direction, after touching N_OT signal, it will immediately move in forward direction and exit from 
the signal. After disengagement, the motor will move in reverse direction again and stop until it reaches 
N_OT. This origin return method only supports in reverse direction. 

 

Figure 4.2.1  
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4.3 Origin sensor and Z-phase 

After "Operation ready" and "Servo ready" turn to green light, click Origin return. When the motor moves 
in reverse direction, after touching EXT-PROBE1 signal of origin sensor, it will immediately move in forward 
direction and exit from the signal. After disengagement, the motor will move in reverse direction again and 
stop until it reaches EXT-PROBE1 signal of origin sensor. 

 

Figure 4.3.1 

Supplementary note: 
1. The above are the three origin return methods supported by Keyence positioning motion unit. For other 

methods and detailed information, please refer to chapter 8 in "KV-XH16ML/XH04ML User's Manual." 
2. The origin sensor and DOG signal for origin return will correspond to EXT-PROBE1 input signal of the 

drive. 
3. EXT-PROBE1 related functions are only supported by Thunder 1.9.20.0 or above and drive firmware 

version 2.8.16 or above. 
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