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Related Documents 

Through related documents, users can quickly understand the positioning of this manual and the 

correlation between manuals and products. Go to HIWIN MIKROSYSTEM’s official website → Download 

→ Manual Overview for details (https://www.hiwinmikro.tw/Downloads/ManualOverview_EN.htm). 
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Preface 

This manual provides detailed information on the operation of PLC software KV STUDIO when E series 

EtherCAT drive is used with KEYENCE KV-7000 series PLC. 
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Specifications of Software/Hardware 

Name Version of Software/Firmware 

E1 Series EtherCAT Drive 

Software (Thunder): 1.9.17.0 or above 

Firmware: 2.8.16 or above 

ESI file: HIWIN_MIKROSYSTEM_ED1F_20221209 or above 

E2 Series EtherCAT Drive 

Software (Thunder): 1.9.7.0 or above 

Firmware: 3.9.16 or above 

ESI file: HIWIN_MIKROSYSTEM_ED2F_20230614 or above 

KEYENCE KV-7500 
Software (KV STUDIO): 11.61 or above 

Firmware: 2.303 or above 

KEYENCE KV-XH16EC Firmware: 1.004 or above 
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1.1 Introduction of hardware device 

 

Figure 1.1.1 

KEYENCE KV-7500 is a controller composed of a CPU unit and one or more positioning motion units. For the first 

use, users need to combine CPU unit and positioning motion unit and prepare a 24 VDC 1.8 A power supply for 

CPU unit. CPU unit is used to connect with the computer, and positioning motion unit is used to connect with the 

drive. 

 

Figure 1.1.2 

Table 1.1.1 

NO. Description 

A Model of CPU unit  

B LCD screen display  

C Computer USB port  

D CPU unit network port  

E LED display lights Green light: Successful connection Red light: Connection failure 

F 
Model of positioning 
motion unit 

 

G Motion unit network port  
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1.2 Create new project 

1. Open KV STUDIO and click File→ New project. 

 

Figure 1.2.1 

2. Enter the project name and select a location. Click OK. 

 

Figure 1.2.2  
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3. Successfully create a new project. 

 
Figure 1.2.3 

1.3 Open the project 

1. Open KV STUDIO and select File→ Open project. 

 

Figure 1.3.1  
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2. Select the saved project and click Open. 

 

Figure 1.3.2 

4. Successfully open a new project. 

 
Figure 1.3.3  
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1.4 Select connection type 

1. Click on communication setting, select a connection path for the controller and click OK. 

 

Figure 1.4.1 

1.5 IP setting and connection 

1. When the controller (CPU unit) is set as default, it is required to use a USB cable for CPU unit 

connection to open the KV STUDIO software interface. (If the controller is not set as default, skip to 

step 7). 

 

Figure 1.5.1  
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2. Create a new project. 

 
Figure 1.5.2 

3. Right-click on the Unit configuration to open Unit Editor. 

 

Figure 1.5.3  
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4. Acquire the configuration information of the unit connected to the PLC to automatically read the 

existing positioning motion unit model of the user. 

 
Figure 1.5.4 

5. Check if the communication path is USB, and click PLC Transfer to store the files in PLC. (It is normal 

if "PLC error" occurs, users can click Clear to erase it.) 

 
Figure 1.5.5  
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6. Execute PLC Transfer, and the display light of the positioning motion unit will turn from red to green, 

indicating the successful setting of the CPU unit and the positioning motion unit. 

 

Figure 1.5.6 

7. Set computer IP address to 192.168.0.100, which is in the same network domain as the controller 

(192.168.0.10) and use Ethernet cable to connect. If the CPU unit is not set as default, users can 

use a network cable or USB to connect to the CPU unit. 

 

Figure 1.5.7  
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8. Create a new project. (This step can be skipped if the project has already been created.) 

 
Figure 1.5.8 

9. Click the communication setting and switch to the Ethernet. Enter 192.268.0.100 in the IP address 

of the computer. (Users can skip to step 12 if using a USB for communication). 

 

Figure 1.5.9  
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10. Select the Network card that is connected to the controller and click on Execute. 

 
Figure 1.5.10 

11. After successful execution, select the Search results below and click Select. 

 

Figure 1.5.11  
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12. Right-click on the Unit configuration to open Unit Editor. 

 
Figure 1.5.12 

13. Acquire the configuration information of the unit connected to the PLC to automatically read the 

existing positioning motion unit model of the user. 

 
Figure 1.5.13  
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14. Click PLC Transfer to store the files in PLC. (It is normal if "PLC error" occurs, users can click Clear 

to erase it.) 

 
Figure 1.5.14 

15. Execute PLC Transfer. 

 

Figure 1.5.15  
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2.1 Axis configuration setting 

2.1.1 Install ESI files 

1. Expand the default positioning motion unit and double-click the Axis configuration setting. 

 
Figure 2.1.1.1 

2. Click the Register ESI file and select the latest ESI file for E series drives. 

(Path: C:\Thunder\doc\ESI Files). 

 
Figure 2.1.1.2  
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2.1.2 PDO setting 

1. Double-click or drag the drive to be selected, and the Slave detailed setting window will pop up. 

 

Figure 2.1.2.1 

2. On the PDO mapping tab, set the PDO according to the requirement. (Users can first select the PDO 

combination and click add or delete afterwards.) 

 

Figure 2.1.2.2 

Note: The number of PDO Read and PDO Write is limited to 8 each.  
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3. On the Motion function setting tab, right-click and select the Automatic assignment option and 

click OK. 

 
Figure 2.1.2.3 

4. After the PDO setting is completed, users need to enter the relevant information of the motor in the 

lower right corner. Click OK after the setting is completed. 

 
Figure 2.1.2.4 

Note: If the Axis configuration setting is completed, click OK and Yes. The coordinate transformation 

calculation that pops up at this time can be ignored, which would be set in the subsequent steps.  
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2.1.3 Object setting (N-OT, P-OT, DOG) 

For detailed information on the object 0x60FDh, please refer to section 3.2 Standardized device profile 

area in "E Series Servo Drive EtherCAT(CoE) Communications Command Manual." 

◆ Method 1: According to the user I/O setting, set N-OT, P-OT, and DOG signals to Input 16 (I1), Input 

17 (I2), and Input 18 (I3) in object 0x60FDh. 

 
Figure 2.1.3.1 

In the IO setting interface in Thunder, tick User defined and set all the Input to Not configure. 

 
Figure 2.1.3.2  
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◆ Method 2: According to the pin definition of 0x60FDh, set the N-OT, P-OT, and DOG signals as bit 0, 

bit 1, and bit 2 in object 0x60FDh. 

 
Figure 2.1.3.3 

In the IO setting interface in Thunder, tick User defined and set the Input pins for N-OT, P-OT, and 

DOG signals. 

 

Figure 2.1.3.4 
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2.2 Axis control setting 

1. Double-click the Axis control setting, set the coordinate unit and the place of the decimal point, 

and then click the coordinate transformation calculation at the top. 

 

Figure 2.2.1 

Table 2.2.1 

Category Name Description 

Unit coordinate 
transformation 

Unit of coordinate Unit: mm, inch, deg, PLS 

Place of decimal point When the coordinate unit is set to PLS (pulse), the setting is invalid. 

2. After the relevant parameters are set, click execute the calculation. Then, click OK and click Yes. 

Note: The setting is based on the resolution of 8388608 pulse/rev for one motor revolution (1mm) and 1:1 electronic 

gear ratio as an example. If the speed is 1 mm/s, the motor speed will be 60 rpm. 

 

Figure 2.2.2  
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3. Axis parameter setting. (Set the parameters in table 2.2.2). 

 

Figure 2.2.3  
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Table 2.2.2 

Category Name Description 

Operation speed 

Operation starting speed 
In positioning control, the momentary starting speed which 
starts from a static state is the operation starting speed. 

Max. operation speed 
Set the upper limit of the position control speed and enter the 
rated speed of the motor. 

Operation acceleration 
rate/time 

Unit: ms, coordinate unit/s/ms 

Operation deceleration 
rate/time 

Unit: ms, coordinate unit/s/ms 

JOG 

JOG starting speed Unit: coordinate unit/s 

JOG high speed Unit: coordinate unit/s 

JOG acceleration 
rate/time 

Unit: ms, coordinate unit/s/ms 

JOG deceleration 
rate/time 

Unit: ms, coordinate unit/s/ms 

JOG inching movement The moving speed is set as the JOG starting speed. 

Origin return 

Origin return method Set origin return method. 

Origin return starting 
speed 

Set the starting speed for origin return and the starting speed 
moving to the home position. 

Origin return creep speed 
The speed when motor reaches the final origin during origin 
return. 

Origin return acceleration 
rate/time 

Unit: ms, coordinate unit/s/ms 

Origin return deceleration 
rate/time 

Unit: ms, coordinate unit/s/ms 

Origin return direction 
Select the start direction for origin return and the operating 
direction before origin return is completed. 

Origin coordinate Set the current coordinates when origin return is completed. 

Movement after DOG ON 
Do not set the parameter to 0 when the origin return method is 
selected as "DOG type inching (with Z-phase)" or "DOG type 
inching (without Z-phase)." 

Absolute position 
follow-up control 

Operation speed 
Set the operation speed for the absolute position follow-up 
control. 

Acceleration rate/time Unit: ms, coordinate unit/s/ms 

Deceleration rate/time Unit: ms, coordinate unit/s/ms 
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4. Click PLC Transfer to store the files in PLC. (It is normal if "PLC error" occurs, users can click Clear 

to erase it.) 

 
Figure 2.2.4 

4. Save the project. 

 
Figure 2.2.5  
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3.1 Homing 

1. Click PLC Transfer to store the files in PLC. 

 
Figure 3.1.1 

2. Switch the KV STUDIO mode to Monitor. 

 
Figure 3.1.2  
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3. Click the adopted positioning motion unit. Right-click and select Trial run→ Positioning control→ 

Axis. 

 
Figure 3.1.3 

4. Check if “Axis error” turns to red light. If there is an error, click Error clear first; if there is no error, 

click OP. Enable. When "Operation ready" turns to green light, click servo ON and wait for “Servo 

ready” light to turn green. After completing "Servo ready," users can execute Origin return. 

 
Figure 3.1.4 

Note: 

1. The above is the operational method for homing. For detailed information, please refer to section 8.4 Origin 

Return Operation Trajectory in the Positioning/Motion Unit "KV-XH64EC/XH32EC/XH16EC User’s Manual." 

2. For the limit switch setting for homing, please refer to section 2.1.2 PDO setting.  
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3.2 Positioning control 

1. Switch the KV STUDIO mode to Monitor. 

 
Figure 3.2.1 

2. Click the positioning motion unit to be used, right click and select Trial run→ Positioning control→ 

Axis. 

 
Figure 3.2.2  
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3. Check if “Axis error” turns to red light. If there is an error, click Error clear first; if there is no error, 

click OP. Enable. When "Operation ready" turns to green light, click servo ON and wait for “Servo 

ready” light to turn green. After completing "Servo ready", users can execute JOG in 

forward/backward direction. 

 
Figure 3.2.3 

4. When JOG is moving, open Scope in Thunder to monitor the feedback velocity of the motor (Observe 

physical quantity: 7-Motor velocity) and check if the velocity command of the controller is consistent 

with the actual feedback velocity of the motor. For example, when the JOG high speed is set to 10.00 

mm/s, the motor velocity can be obtained as 600 rpm when the unit is converted into rpm according 

to the setting of coordinate transformation calculation. 

 
Figure 3.2.4  
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3.3 Starting speed, acceleration and deceleration rate/time, 

acceleration curve 

1. Complete the parameter setting in Figure 3.3.1 with the above-mentioned setting method. 

 
Figure 3.3.1 

2. Open Thunder, click Tools→ Real-time data collection. Then, input the position command velocity 

"dPosVelCmd" and click Start (F5) to capture the data. 

 

Figure 3.3.2  
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3. Press and hold JOG to move the motor for a certain distance and release it. Wait for the motor to 

stop. 

 
Figure 3.3.3 

4. Open Thunder→ Real-time data collection, click Stop and then click Graph (refer to Figure 3.3.2) 

to generate Figure 3.3.4. 

 
Figure 3.3.4  

Speed 

(rpm) 
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5. According to the setting in chapter 2 that the resolution for one motor revolution (1mm) is 8388608 

pulse/rev, 1.00 mm/s starting speed corresponds to 60 rpm actual speed; 25.00 mm/s JOG high 

speed corresponds to 1500 rpm actual speed. Choose SIN for acceleration curve since the speed 

command from starting speed to high speed is in a curved shape; choose a straight line for 

deceleration curve since the speed command from high speed to starting speed is in a straight line. 

The acceleration/deceleration time of 0.010 mm/s/ms corresponds to the actual acceleration of 0.6 

rpm/ms, indicating that the speed increases by 0.6 rpm every 1 ms. 

 

Figure 3.3.5 
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